[Vol-users] segmentation fault

Anna Giannakou anna.giannakou at inria.fr
Wed Apr 27 03:17:54 CDT 2016


Hello, 

I am using volatility in order to do live introspection in a linux virtual machine (i m using libvmi and pyvmiaddresspace.py to access the vms memory). 
The problem that I am facing is that once i run a command for example linux_pslist I get a segmentation fault(core dumped) error with no further information about it. 
Some general information about the system: 
I have recompiled libvmi in order to work with the kvm-qemu patch and I have tried the process-list example for linux that is featured with libvmi and it works fine. 
I have also tried to manualy execute 
pyvmi.init("instance-name","partial") which is what pyvmiaddresspace.py is doing and this also works (along with all the pyvmi related commands like get_memsize(), get_vcpureg()). 
>From what I understand the problem should lie somewhere in volatility. Before the recompilation of libvmi everything was working fine (without the kvm patch). 
Any help would be greatly appreciated. 

Thanks 
Anna 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.volatilityfoundation.org/pipermail/vol-users/attachments/20160427/fdeb19a5/attachment.html


More information about the Vol-users mailing list