<div dir="ltr">Hey George, <div><br></div><div style>Does WinPE/WinFE have WMI and/or PowerShell? If so, you could try one of those:</div><div style><br></div><div style><a href="http://blogs.technet.com/b/heyscriptingguy/archive/2012/02/28/use-powershell-to-configure-static-ip-and-dns-settings.aspx">http://blogs.technet.com/b/heyscriptingguy/archive/2012/02/28/use-powershell-to-configure-static-ip-and-dns-settings.aspx</a><br>
</div><div style><a href="http://theinterw3bs.com/wiki/index.php?title=WMIC_Commands#Remotely_change_the_IP_to_a_static_IP_.28Index_is_Interface.23.29">http://theinterw3bs.com/wiki/index.php?title=WMIC_Commands#Remotely_change_the_IP_to_a_static_IP_.28Index_is_Interface.23.29</a><br>
</div><div style><br></div><div style>MHL</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Jun 3, 2013 at 12:36 PM, George M. Garner Jr. <span dir="ltr">&lt;<a href="mailto:ggarner_online@gmgsystemsinc.com" target="_blank">ggarner_online@gmgsystemsinc.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">This post is off-topic; however, there are a lot of bright people on this list so maybe someone will be able to help.  I need to set a static ipv4 address on an interface in WinPE4.0/WinFE4.0.  For example the following command works on Windows 8:<br>

<br>
netsh.exe interface ip set address Ethernet static 192.168.0.5 255.255.255.0<br>
<br>
On WinPE 4.0 I am getting an error that the interface is not found which<br>
is odd since the interface appears in the list of interfaces.  For example:<br>
<br>
netsh.exe interface ip show interfaces<br>
<br>
and<br>
<br>
netsh.exe interface ip show interface Ethernet<br>
<br>
both work as expected.<br>
<br>
I can also add a route on the interface in WinPE, e.g.:<br>
<br>
netsh.exe interface ip add route <a href="http://192.168.0.0/24" target="_blank">192.168.0.0/24</a> Ethernet<br>
<br>
works.  It is just adding the static ip address that doesn&#39;t work.  I<br>
have also tried using the IF index instead of the interface name; still<br>
no joy.  Unfortunately I can&#39;t use dhcp in some applications because the<br>
client broadcasts an announcement that I am present, which wouldn&#39;t be prudent.<br>
<br>
I am wondering if there isn&#39;t maybe some dependency that is missing from<br>
my winpe installation?<br>
<br>
Anyone have any thoughts?<br>
<br>
Regards,<br>
<br>
George.<br>
______________________________<u></u>_________________<br>
Vol-users mailing list<br>
<a href="mailto:Vol-users@volatilityfoundation.org" target="_blank">Vol-users@volatilityfoundation.org</a><br>
<a href="http://lists.volatilityfoundation.org/mailman/listinfo/vol-users" target="_blank">http://lists.volatilesystems.<u></u>com/mailman/listinfo/vol-users</a><br>
</blockquote></div><br></div>